Funzione SOMMA.SE a due criteri.

La funzione SOMMA.SE viene usata per sommare dei valori in un'intervallo SE in un'altro intervallo esistono dei valori uguali al criterio stabilito. (Vedi articolo "Funz. =SOMMA.SE" sull'altro sito)

La sua sintassi è : =SOMMA.SE(interv_dove cercare;criterio da cercare;interv_da sommare)

se "interv_da sommare" viene omesso, viene sommato l'"interv_dove cercare".

Esempio: vogliamo sommare tutti i valori nell'intervallo C1:C5 (interv_da sommare) SE nell'intervallo A1:A5 (interv_dove cercare) compare il valore 53 (criterio da cercare); posizioneremo in un'altra cella la nostra formula (es. in E1) che sarà:

  • =SOMMA.SE(A1:A5;53;C1:C5)

  A B C D E F
1

53

 

10

 

90

 
2

22

 

20

     
3

53

 

30

     
4

87

 

40

     
5

53

 

50

     

Una limitazione della funzione SOMMA.SE è che accetta un solo parametro come criterio da cercare, e se i criteri sono due? Una possibile soluzione la troviamo nell'articolo "SOMMA.SE+CONCATENA" sull'altro sito, ma esistono altre soluzioni, compreso le due che illustro di seguito.

Supponiamo di voler sommare tutti i valori nell'intervallo C1:C5 se in A1:A5 è presente il valore 53 e se nell'intervallo B1:B5 compare il nome "Rossi"; abbiamo quindi la necessità di valutare 2 criteri in due diversi intervalli. Non potremo usare la formula vista sopra, Excel non accetterebbe soluzioni tipo

  • =SOMMA.SE(E(A1:A5=53;B1:B5="Rossi");C1:C5) o similari

Intanto vediamo una possibile tabella:

  A B C D E F
1

53

Rossi

10

 

60

 
2

22

Verdi

20

     
3

53

Bianchi

30

     
4

87

Rossi

40

     
5

53

Rossi

50

     

Prima soluzione:

  • Usare una colonna, per esempio da D, dove inserire, a partire dalla cella D1, trascinando poi per quanto necessita, nelle celle sottostanti, una formula condizionale che verifichi  i due criteri, e restituisca 1 (oppure VERO) o 0 (oppure FALSO), una formula che sfrutti anche la funzione E per valutare più parametri, così:

  • =SE(E(A:A=53;B:B="Rossi");1;0)

Questa formula produrrebbe questo risultato:

  A B C D E F
1

53

Rossi

10

1

60

 
2

22

Verdi

20

0

   
3

53

Bianchi

30

0

   
4

87

Rossi

40

0

   
5

53

Rossi

50

1

   

Ora possiamo usare la funzione SOMMA.SE che verifichi se nell'intervallo D1:D5 compare il numero 1, e allora sommi i valori in C1:C5

  • =SOMMA.SE(D1:D5;1;C1:C5)

Spesso in Excel può essere utile sfruttare passaggi intermedi per raggiungere i nostri obiettivi, e questo visto sopra ne è un'esempio.

Seconda soluzione:

  • Usare una formula condizionale matriciale, che ci consente di ottenere con una unica formula il risultato voluto. Ricordo che per impostare una formula matriciale è necessario, al posto di premere il solo INVIO dopo che si è scritta la formula, premere contemporaneamente i tasti CTRL+MAIUSC+INVIO, e questa è la formula:

  • {=SOMMA(SE((A1:A5=53)*(B1:B5="Rossi");C1:C5;0))}

La matriciale si riconosce dalle parentesi graffe che racchiudono la formula, parentesi che appaiono seguendo la procedura tasti vista sopra.

 

Buon lavoro.

prelevato sul sito www.ennius.altervista.org